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MCD2快速入门篇： 
第一章、安装MPLAB IDE软件： 
1.1 先不要连接硬件，将产品配套光盘放入要安装软件的电脑光驱内，打
开光盘下\mplab ide文件夹，执行下面的MPLABV6.XX.exe或者MPLAB 
V7.XX.exe开始安装软件(推荐用较新版本的软件)。 
1.2按提示操作执行软件的安装，安装完成后重新启动计算机。 

***注意:在WIN98系统安装 IE6.0的环境下，MPLAB IDE安装完后调
用 IE显示帮助文件时，被 IE6.0拒绝，之后运行 MPLAB IDE会出现"非
法操作"然后退出（解决方法：主要原因是安装程序因为 IE6.0的无法调用
而退出，后面的动态连接库没有注册到 WINDOWS 的注册表。只要执行
C:/Program Files/MPLAB IDE/dlls/egister.bat便可解决问题。）*** 
  ***Windows xp操作系统可能需要管理员权限才能正确安装该软件*** 
如果安装的软件不能打开或使用，可能是光盘在刻录时数据丢失，这时

就请你到我们的网站“技术资料”一栏重新下载MPLAB IDE软件并安装。 
第二章、设置串口属性： 
(不用串口的用户可直接跳过这一步) 
2.1先不要连接硬件,打开“我的电脑”进入“控制面板”，执行“控制面板”
下“系统”，进入“硬件”一栏点击“设备管理区”，进入设备管理区点击

“端口（COM和 LPT）”，下拉出电脑现在存在的几个端口. 
2.2 现在将对我们 MCD2 将要使用的串口进行设置(注意:设置好以后，
MCD2 必须固定这个串口或 USB 口)，双击我们要使用的串口如:“通信端
口（COM1）”，此时将弹出 COM1 的属性设置窗，进入“端口设置”一
栏，将串口的流控制设为硬件，如下图： 
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2.3点击“高级（A）”进入缓冲设置窗口，关闭串口的使用 FIFO缓冲区，
即将前面的钩去消，如上图. 
2.4 设置好以后点击“确定”退出高级设置，再点击“确定”退出串口属
性设置，关闭设备管理区以及控制面板等。 
2.5重新启动电脑使上面的硬件设置生效.(此步骤切勿忘记！否则，上述设
置不会生效) 
***更换其它串口时需要对新更换的串口如 COM2重新作上述设置*** 
第三章、USB驱动程序的安装 
3.1用随机配套的USB连接线连接MCD2主机至电脑，先不用连接用户板。 
3.2 USB驱动程序的安装过程见：《PIC16-MCD2使用说明书》的第 20页
-第 23页。 

MPLAB IDE V6.XX的 USB驱动程序位置: 

驱动程序在 C:/Program Files/MPLAB IDE/Drivers2000/ICD2_USB子

目录下（如果是 windows98/ME，则为 icd2w98.inf，在 C:/Program 

Files/MPLAB IDE/Drivers98/ICD2_USB子目录下）.  

MPLAB IDE V7.XX的 USB驱动程序位置: 

驱动程序在 C:/Program Files/Microchip/MPLAB IDE/ICD2/Driver/

子目录下.(这儿默认 MPLAB IDE安装在 C盘，如果你的 MPLAB IDE安

装在 D盘则把相应的地址改成 D盘就行)   
注意: 不要在安装MPLAB IDE 前将MCD 2与 PC通过 USB连接。 

问: 当我安装驱动时， 为什么驱动无法找到， 尽管我能在驱动文件夹中
看到它们， 并且我将驱动向导指向正确的文件夹? 
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答: 碰到这个问题， 可以退出驱动安装向导， 进入控制面板的”添加新硬
件”. 在系统搜索新硬件后， 选择”不， 设备不在列表中.” 然后选择”不， 
我想从列表中选择硬件”. 然后选择” 通用串行总线控制器”， 当”磁盘安
装” 按钮出现时， 进入到驱动文件夹， 选择正确的驱动。) 
第四章、MCD2初步 
(这一章让大家熟悉 MCD2的一些软件设置) 
4.1 针对 MCD2来配置 MPLAB IDE 
4.1.1 硬件连接[参照第七章中的“硬件连接方法二”] 
• 用 USB线或串口线连接 PC与 MCD2主机，并给 MCD2仿真器供外
部 9V电源; 

• 用 6芯水晶头线一端插入 MCD2主机，另一端插到目标板 ICSP接口
/ICD2仿真接口(注意目板板上要放置好被仿真的芯片); 
注: 6芯线可以直接将 MCD2连接到目标板，而不需要仿真头(部分少引脚

芯片需要专用仿真头).目标板在布板时需预留一个 6芯/5芯 ICSP插针

接口（其中 RB3不用接）,接口的连接顺序详见第六章。  
特别注意：在MPLAB IDE运行时，不要断开 USB电缆或串口电缆，若
断开可能会导致 ICD0019,ICD0021的错误发生。 
如需要断开 USB电缆或串口电缆，请先退出 MPLAB IDE. 
重新插入 USB电缆后，不要立即启动 MPLAB IDE(否则也会导致上述错
误的产生)，要等 8秒左右，因为系统对 USB的识别需要一段时间。 
操作技巧：在开发过程中 USB或串口电缆始终连着，但在线调试（ICSP）
电缆可根据需要断开或连接。 

4.1.2 开始 MPLAB IDE 
在安装完MPLAB IDE软件后， 使用下面任何一种方法来启动它: 
• 选择开始>程序>Microchip MPLAB IDE>MPLAB IDE. 
• 双击桌面MPLAB IDE图标 
• 执行MPLAB IDE安装路径下\dlls子目录下的mplab.exe. 

4.1.3 选择器件 
使用器件选择对话框Configure>Select Device来选择MCD2要调试
的器件(我们公司 QL200/MCD DEMO实验板所配器件为 PIC16F877A,
不能选择为 PIC16F877,两个是完全不同的器件).  
注: MCD2 所支持的器件会在 Microchip 工具支持下面紧挨着 MPLAB 
ICD2 旁边有一个绿灯图标.不支持的器件会有一个红灯图标. 黄灯图标
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表示那个器件可以选择， 但它会有某些限制， 可能不适合于量产工作.
但它可以让MCD2做初步的使用. 

4.1.4配置字的设置. 
使用配置字选择对话框 Configure>Configuration Bits 来设置当前
项目的配置位. 
• Oscillatot 振荡方式先择，根据用户板的硬件进行选择，如本站的

MCD-DEMO板出厂默认为 4M晶振电路，我们选择振荡方式为 HS/XT。 
• Watchdog Timer 看门狗使能位，用MCD2作调试工具时该项一定
要选择为 off 
• Power Up Timer 上电廷时使能位，一般选择为 on有利于芯片起振,
也可以选作 off 
• Brown Out Detect 掉电检测使能位，用MCD2作调试工具时一定
要选择为 off 
• Low Voltage Program 低压编程使能，用 MCD2时一定要选择为
Disabled 
• Flash Program Write 写 FLASH使能，用MCD2作调试工具时一

定要选择为Write Protection off 
• Data EE Read Protect 读内部 EEPROM保护位，用 MCD2作调试

工具时一定要选择为 off 
• Code Protect 加密位， 用 MCD2作调试工具时一定要选择为 off 

4.1.5设置 MPLAB ICD2作为调试工具 
选择 Debugger>Select Tool>MPLAB ICD2将 MPLAB ICD2作为调
试工具. 一旦这个工具被选择， Debugger菜单和 MPLAB IDE工具条
会显示调试选项. 同时，OUTPUT窗口会打开，关于 ICD2状态和通讯
的信息会显示在 OUTPUT窗口内.（注意：ICD2作为调试工具时所烧写
的程序只能用于仿真调试，不能够脱机使用，若要烧写能脱机使用程序，

就要选择 Programmerr>Select Programmer>MPLAB ICD2 将
MPLAB ICD2作为编程工具） 

4.1.6设置 MCD2 
第一次使用 MCD2推荐用 MPLAB ICD2安装向导来设置 MCD2 

  执行 Debugger>MPLAB ICD2 Setup Wizard来运行 MPLAB ICD2
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安装向导，按照提示执行 设置好所有选项（设置方法参考下

面图示：），最后点击“完成”来结束安装向导. 

   

 

 

 

以后更改端口可直接在:Debugger>Settings的Communication界面. 
    以后更改电源设置可直接在 Debugger>Settings的 Power界面. 
4.1.7更新 MCD2固件(操作系统)  
根据 MPLAB IDE的版本或器件的选择， 可能会提示一条信息显示固

件需要更新. MPLAB IDE将自动安装新的固件. 更新对话框如图所示: 

 
同时， 不同的MPLAB ICD2固件用于不同系列的 PIC单片机， 当切

换不同的 PIC单片机时也可能出现这个对话框. 
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固件可以按照下面的步骤手动更改(正常使用通常无需手动更新): 
1. 选择 Debugger>Download ICD2 Operating System. 选择

ICD2固件文件对话框会打开. 
2. 从列表中或浏览器中选择要下载的固件文件. 文件名的组成为

icdxxxxxx.hex，其中 xxxxxx为版本号. 关于MPLAB IDE提供最
新版本的信息可以查看README文件或MPLAB ICD2.txt.根据选
择的 PIC器件版本可能会变动. 

3. 点击 Open. MPLAB IDE将下载新的操作系统到 MCD2. 
4.1.8 应用电源 
针对 MCD2和目标板有许多的配置，下面是这些配置的关键： 
• 当使用USB连接时，USB可给MCD2供电，但不能给目标板供电，如
果目标板电源来自MCD2，就必须给MCD2主机接一个随机配套的外部
9V电源。 
• 当使用RS-232连接到PC机时，MCD2必须接一个外部9V电源。 
• 当MCD2有一个自己的电源时，它可以对较小的目标板在5V电压下
提供一定能量的电流，最高可达200mA（本公司的MCD-DEMO/QL200
可用来自MCD2主机的电源）。 
• MCD2不能由目标板供电。 
• 如果用户板用自己的电源，在给目标板加电之前，应先给MCD2加电。 

4.2 当MCD2给目标板供电时的上电顺序. 
这个配置只允许用户板工作在5V， 最高200mA电流下使用。 

1. 给MCD2加外部电源并连好与电脑的通信线，用电话线连接MCD2
到目标板，(不要给目标板供电)。 

2. 启动MPLAB IDE，执行完上面4.1.2---4.1.6的所有步骤，注意4.1.6

步骤中第三步设置如右图：  

3. 在MPLAB IDE的Debugger菜单下，选择Connect。 
4. 此时目标板就应该会得到由MCD2供出的5V电源了，接下来等待执
行其它操作。 

4.3 当目标板有一个独立电源时的上电顺序 
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对于这个配置，目标电源可以是 3-5V，电流可以比MPLAB ICD2提供
的电流高。查看芯片数据手册以确认目标器件所使用的操作电压范围。 

1. 给MCD2加外部电源并连好与电脑的通信线，用电话线连接MCD2
到目标板，先不给目标板供电。 

2. 启动MPLAB IDE，执行完上面4.1.2---4.1.6的所有步骤， 注意4.1.6

步骤中第三步设置如右图：  

3. 在MPLAB IDE的调试菜单下，选择Debugger>Connect (这时可能
会提示0020的错误，先不用理它)。 

4. 在建立通讯后，给目标板上电，然后再选择Debugger>Connect. 
第五章、MCD2实战 
这则指南将会使用例程mcd-led1.asm来介绍开发一个简单工程的过程. 

这个例程在 MCD2 的产品配套光盘的 MCD-DEMO 编程实例文件夹中可
以找到. 这个程序使用本站 MCD-DEMO 演示板来实现 PIC16F87X 的流
水灯,使用其它开发板或目标板时操作流程及方法可借鉴.  
5.1 文件名及文件地址注意事项: 
将随机配套光盘下的mcd-demo编程实例文件夹整个复制到电脑的硬
盘上，并将文件夹名包括上层上上层文件夹全部改名为英文或数字(注
意:MPLAB要求源程序或项目的文件名以及文件地址不能含有中文或字
符串),最后去掉文件夹内所有文件的只读属性。 
5.2 执行第四章4.11-4.16的所有步骤连接好硬件并设置好MCD2各选项. 
器件选择为:877A 

  配置字设置如下:  
• Oscillator – XT/HS(这是针对MCD-DEMO. 如果使用其它的目标
板，应根据硬件进行相应的变更) 
• Watchdog Timer – off 
• Power Up Timer – off 
• Brown Out Detect – off 
• Low Voltage Programming – Disabled 
• Flash Program Write - Write Protection off 
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• Data EE Read Protect – off 
• Code Protect - off           

5.3 运行工程向导 
   在这个工程中， MPASM汇编器会被使用. 
1. 选择 Project>Project Wizard来建立第一个工程. 
2. 进行到第二个向导对话框， PIC16F877A 应该被选中(若没有，请
下拉选择芯片为 PIC16F877A). 

3. 继续进行到向导的下一个对话框 ,设置 MPASM 作为语言工具 . 
在”Active Toolsuite”下拉列表中选择”Microchip MPASM Toolsuite”.确
认 MPASM、MPLAB 和 MPLINK 设置在正确的路径上；MPASM 应指定
到 mpasmwin.exe，MPLINK 应指定到 mplink.exe，MPLAB 应指定到
mplib.exe.部分电脑可能因系统不能为它们指定正确的地址而出现红色错
误标志，这时你只需要人为的为其指定地址，方法是:选中红色标志选项，
然后点击下面 Location区的 Browse按钮，找到正确的地址并点击打开
(一般三个文件在同一个文件夹，通过正确文件的路径就能方便的找出有红
色标志文件的路径)，路径正确后就没有红色的错误标志了，如下图 
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  点击下一步，输入工程文件及项目名以及指定保存项目的文件夹（建
议保存到源程序同一个文件夹，项目名及各层文件夹名不用有中文及字符

串。）接着工程文件被添加到向导。 
点击下一步，添加源文件，也可以在以后添加，对于这个例子，选择

刚才复制在硬盘上的 mcd-led1.asm，点击 mcd-led1.asm 来选中它， 然
后点击 ADD>>将它添加到右边的面板，如上图。 
点击下一步这个工程文件就建立完成，点击完成退出向导。 

5.4 查看工程 
退出向导后，MPLAB IDE窗口左侧工程窗口应该如下图所示。 

                    
如果有错误，  文件可以手动的添加到工程窗口 . 将光标移动

到”Source Files点鼠标右键选中 Add Files来添加文件. 要删除一个文
件，可以先选中它，然后点击鼠标右键选中 Remove从工程中删除文件。 
5.5 创建 HEX文件 

要为调试创建一个 HEX文件， 选择 Project>Build All或在工程窗
口里的工程名字上点击右键并从弹出的菜单上选择”Build All”编译源. 
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MPASM汇编器总会以.asm文件相同的名字生成一个.hex文件. 
  编译时会打开一个状态窗口，显示编译的进度与最后的结果，编译结果
显示为“BUILD SUCCEEDED”，就表示编译成功了。 
5.6设置演示板 
在开始调试前， 确认 MCD-DEMO演示板按如下进行设置: 
• 使用跳线选择振荡电路为外部 4M晶振。    
• 根据 ASM文件顶部或底部提示设置拔码开关及跳线。 
• 设置目标板上其它跳线，如电源选择跳线…… 

5.7 载入调试代码 
选择 Debugger>Connect将MCD2与 PC建立连接. 
连接过程若出现 ICDWarn0020找不到目标器件，出现这项提示时请确认： 

1.用户板上的芯片是否放置正确（查看软件中选择的芯片型号是否与目
标板上一致） 
2.芯片与主机之间的通信良好（检查MCD2和目标板的连线是否正常） 
3.电源设置是否正确,如果目标板电源由仿真器供给，仿真器必须有加
外部 9V电源，同时检查软件选择的供电方式是否与实际设置相符。 
4.更换目标芯片试试（如果芯片已使用较长时间，有可能芯片已坏）. 
5.芯片的调试引脚(MCLR,PDG,PDC)线路上是否有电容或电感或二极
管，如果有，请去除,如果目标板MCLR引脚直接连接 VDD请断开（正
常MCLR应该通过 10K电阻上拉到 VDD）。 
6.确认调试连接线（ICSP）是否有接错序或接反或接错目标芯片引脚. 
7.部分少引脚数的芯片需要专用仿真头才能调试。 
注：如果你是用的我公司开发板 /目标板，且目标芯片为标配
16F87X(A)，就不会存在后面的三个问题。 

选择 Debugger>Program将当前程序与调试代码编程到MCD-DEMO演
示板上的 PIC16F877A(注：PIC的在线仿真器不同于其它仿真器，其它仿
真器仿真前不需要执行编程的操作，而 MCD2 在仿真前必须要执行
Debugger>Program将当前程序与调试代码都写进目标芯片才能做单步/
断点/全速等调试动作).编程可能需要几秒钟，在编程过程中， OUTPUT
会显示操作的当前阶段. 当编程完成时， 对话框应该如下图所示. 
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编程完成如果出现 ICDWarn0083无法进入调试模式 

出现该错误时，一般为振荡不正常，请确认配置字中的振荡方式，

或者目标板是否起振。其它原因如：目标板供电不足、程序代码被写

保护/加密、部分少引脚芯片需要特定的调试头才能进行调试 
编程完成如果出现 ICD0161提示烧写检验失败时，请确认： 

Connect 时没有 ICDWarn0020 警告；目标芯片的 MCLR/VPP 脚上
没有除上拉外的其他电路（其它复位电路请采用跳线进行隔离）；ICD2
与芯片的接口线路没有与电感或电容特性的电路连接；整个系统可以

提供足够的烧写电流。 
5.8 运行 MCD-LED1 

MCD2可以以实时或单步模式调试，也可以设置 1个断点. 
工具栏按钮可以用于常用调试操作的快速访问. 
调试菜单 工具栏按钮 调试菜单 工具栏按钮 
运行  单步执行  
中止  复位  

开始实时调度模式(前提：已执行 5.1-5.7的操作): 
1. 打开 asm文件(在工程窗口上双击文件名或使用 File>Open). 
2. 选择 Debugger>Run(或点击工具栏 RUN按钮) 
3. 在目标板上观察当前程序的工作过程. 
4. 选择 Debugger>Halt(或点击工具栏 HALT按钮)中止程序运行. 
5. 选择 Debugger>Reset复位程序. 
5.9 调试 MCD-LED1 
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下面的任何一项都能阻止程序的调试工作. 
• 目标板的拔码开关或跳线设置不对。 
• 未正常执行编译及Debugger>Program操作。 
要观察寄存器的改变状态， 可以在程序相关处设置断点. 
1. 从mcd-led1.asm中选中或将光标放置在要设断点的下面一行如: 

btfss    flag，0       ；判断标志位，是1则跳到循环左移 
2. 点击右键， 显示弹出菜单. 
3. 从弹出菜单选择 Set Break Point. 这一行现在被标记为断点(红色的

B停止标记). 如下图所示. 
4. 选择 Debugger>Run(或点击工具栏 RUN 按钮)以实时模式再次运行
程序.当程序执行到断点行时， 断点会中止程序的运行. 然而，例程不
会被中止. 

5. 选择 Debugger>Halt(或点击工具栏上 HALT按钮)来中止程序. 

     

 

6. 要复位程序， 选择 Debugger>Reset. 第一条指令应该显示带一个绿
色的箭头. 

7. 打开一个新的观察窗口来观察程序执行时 FLAG 寄存器值的变化. 选
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择 View>Watch. 观察对话框将Watch选中打开. 从添加 Symbol 旁
边的列表中选择”flag”， 然后点击按钮”Add Symbol”.flag被添加到
观察窗口中.如上图. 
注：观察寄存器请用Watch窗口，如果您打开所有寄存器窗口将会因
反馈的数据太多而造成 MCD2调试缓慢. 

8. 单步执行程序， 选择 Debugger>Step(或点击工具栏 STEP按钮). 
9. 在观察窗口中检查寄存器 FLAG的值.  
10. 选择File>Save保存文件. 
11. 选择Project>Build ALL重建工程. 一条信息会提示程序被重新建立. 
要使改变生效， MCD2必须被重新执行Debugger>Program. 

12. 选择Debugger>Program重新编程. 当MPLAB ICD2对话框显
示’…Programming succeeded’，程序就可以再次进入运行模式. 

13. 在之前设置断点的行点击右键， 选择Remove Break Point移除断点. 
14. 选择Debugger>Run使程序运行在实时模式.  
您实际编写的代码中可能会有很多问题. 使用MCD2和MPLAB IDE调

试功能，您能很快的发现并修复这些问题. 
5.10 编程 
当程序成功的调试并运行时，通常下一步就是对芯片编程使其能够脱

机运行. 当进行这一步时，被MCD2占用的资源将释放给用户. 
对应用进行编程， 可以按照下面步骤: 

1. 选择 Debugger>Select Tool>none关闭MCD2作为调试工具. 
2. 在 Programmer>Select Programmer菜单中选择 MPLAB ICD2作
为编程器. 

3. 在 Programming>Settings程序标签上设置用于编程的参数. 
4. 选择 Programmer>Program. 

现在烧好程序的芯片就能脱机运行了，我们可以点 programmer 菜单

下的 Release from reset 命令，目标板就会进入运行状态。我们也可以

断开 MCD2与用户板的电话线连接并给用户板上电来观察程序的运行. 
使用MCD2作为调试工具的操作顺序总结如下: 

1.连接好硬件 
2.启动MPLAB IDE，选择好器件，并设置好 CONFIG位. 
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3.Debugger->Select Tool->MPLAB ICD2     
4.执行 Debugger>MPLAB ICD2 Setup Wizard 
或者 Debugger->setting-> ...设置好各选项。 
5.建立好工程并载入源程序    
6. Build All    
7. Connect to MCD2 
8.Debugger->Program     
9.Debugger->run 
如果你有 Read芯片，或者修改源程序、更改配置信息就須重复 6、8、

9的步驟。 
更多使用的问题请查询 MCD2使用说明正本第五章与第六章，也欢迎

朋友们到论坛发贴讨论。 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

http://www.pic16.com
http://www.pic16.cn


深圳市乾龙盛电子科技有限公司                www.pic16.com     www.pic16.cn 

第 16 页 

第六章、MCD2主机说明 

 
1---RS232(串口)通信连接口， 通过随机配套串口线实现MCD2到 PC

机的串口通信. 
2---USB复位按键，以代替MCD2连接 USB失败时候出现 ICD0019，

ICD0021提示需要拔插 USB以恢复连接的动作，现在只需要按复
位键后，等待 8 秒左右再连接，即可完成驱动卸载，再安装，建
立通信等过程。（请不要在 USB正常通信的情况下按复位按键）。 

3---USB通信连接口，通过 USB连接线实现与 PC的高速 USB通信. 
注：请不要同时用 USB与串口连接MCD2到 PC. 

4---ERROR错误指示灯.    5---BUSY运行/忙碌指示灯. 
6---POWER电源指示灯. 
7---ICSP输出下载或调试连接口. 
8---MCD2外接电源输入口，适用于AC/DC7.5V-12V，电流大于 200MA
的外部电源输入（不需要考虑电源的正负极）。 

6.1  6PIN连接线说明 A 
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6.2  6PIN连接线说明 B 
1. 建议连接顺序 

先连接MCD2到 PC，等待几秒后启动MPLAB IDE软件，建立通信
后才连接目标板. 

2. 六芯插排线连接说明 
该线是为了你的使用而附赠的，方便直接连接MCD2和目标板。若

你打算直接调试目标板，请在布板时预留该接口。 
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第七章、MCD2硬件连接说明 
硬件连接方法一: 

    
1） 仿真器需连接与电脑通信用的 USB线或串口线，如果目标板采用仿真

器供电，同时仿真器需连接外部 9V电源。 
2） 将要仿真的 40脚芯片如:PIC16F87X（A），作为目标单片机，插放到

MCD2的仿真头上，（如果您要仿真的芯片是 28脚的，请用对于的 40
脚芯片作为仿真芯片，且软件中选择该 40脚芯片的型号）。  

3） 用配套的扁平 6芯电缆把MCD2的主机和仿真头连接。 
4） 仿真 40脚的单片机，就用 2条 20脚插针，将仿真头与目标板上的 40
脚 IC插座对接在一起，如果仿真 28脚的单片机，就借助于 2条 14脚
插针，将仿真头与目标板上的 28脚 IC插座接在一起。 

硬件连接方法二(推荐): 

 

1）仿真器需连接与电脑通信用的USB线或串口线，如果目标板采用仿真器

供电，同时仿真器需连接外部9V电源。 

2）用配套的扁平6芯电缆连接MCD2主机到目标板。 

3) 在目标板上放置欲仿真的芯片如： PIC16F87X（A）单片机。 
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第八章、MCD2/ICD2通用烧写适配器使用指南 
注：QL-120_A3版的适配器使用方法请参照《QL120_A3通用烧写适配器
使用指南》（单页） 
1. 直插器件： 

器件 40PIN器件 28PIN器件 16F57除外 18PIN器件 

开关

设定 

1----ON 

其它全 OFF 

1----ON 

其它全 OFF 

2----ON 

其它全 OFF 

插放

图示

(注意

手柄

位置) 

   

 

14PIN 器件 
8PIN器件 10FXX

除外 
16F57 10FXX 

2----ON 

其它全 OFF 

2----ON 

其它全 OFF 

3----ON 

其它全 OFF 

4----ON 

其它全 OFF 
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2.贴片封装器件 
贴片封装器件的烧写方法有两种 
  方法一:用通用贴片适配器插放在 ZIP锁紧座上烧写，在锁紧座的插放方
法及拔码开关的设定同直插器件一样.(适用于工厂大批量生产). 
方法二:直接在本 PCB上相应位置烧写(不需要设定拔码开关，不需适配

器)，方法是: 将芯片放到 PCB的铜箔处，对齐引脚的位置，用手指轻压，
然后烧写即可(适用于产品开发或小批量使用)，可烧写的芯片有:SOT23-6
脚器件(PIC10FXXX)、SO-8封装器件、SO-14封装器件、SO-28封装器件、
特殊脚位的 SO-28 封装器件（PIC16F57）、QFP44/PQFP44 封装器件、
PLCC44封装器件、TQFP64封装器件。 
3.烧写芯片的流程 
1. 连接好硬件(MCD2/ICD2 用 USB/串口连接电脑，给 MCD2/ICD2 供
外部 9V电源，用电话线将MCD2/ICD2与烧写适配器连接好) 

2. 等待几秒后启动MPLAB IDE软件| 
3. 选择好器件(ConfigureàSelect Device) 
4. 载入要烧写的 HEX文件(File-àImport)，或建立工程载入源代码并编

译。注：若要查看载入的 HEX文件:ViewàProgram Memoryà切换
窗口左下角选项到 Opcode Hex 

5. 设定好配置位（Configureà Configuration Bits） 
6. 选 择 烧 写 工 具 为 MPLAB ICD2 （ Programmerà Select 

Programmerà2.MPLAB ICD2） 
7. 设定好 ICD2/MCD2各参数（ProgrammeràSettingsàPower(将 Power 

target circuit…前面的钩打上)àCommunication 下选择好端口à点应
用退出设定. 

8. 设定好烧写适配器的拔码开关 
9. 在锁紧座上放置好要烧写的芯片àConnect(PASS 后执行下面的过
程，连接失败就先找出原因) 

10. Program(烧写) 
11. 成功后取下芯片放上另外的芯片再执行 Program(烧写)。 
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